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1. Quick Start Guides
The Dayton Audio DSPB series of boards leverages the powerful Analog Devices ADAU1701 DSP chip to
allow for almost limitless possibilities for sound customization. Out of the box, a DSPB-100/250 or a
DSPB-K will allow for quick adjustments with the convenient built in potentiometers, but to unlock the
full potential of the ADAU1701 processor, combine your board with a Dayton Audio DSPB-ICP1 to
connect directly to the SigmaStudio development tool provided by Analog Devices.

A. Before you start
1. Review the wiring diagrams found at the end of this document or on the product page for each
device before using the quick start guide. Refer to these diagrams as you’re following the quick
start guides.
2. Make sure that any speakers and input devices you plan on connecting to the DSPB are working
properly.
3. Take care when attaching and especially removing jumper cables from the DSPB.
a. A damaged cable can cause issues that are difficult to troubleshoot, such as noises like
popping or clicking. A damaged cable can also cause programming issues.
4. To achieve increased power from a DSPB amplifier, try increasing the input volume before
increasing the gain of the amp to max levels. This will generally result in a better response from
the amp.
a. For example, increase the volume of an attached mp3 player before adjusting the
potentiometer on the board to increase output volume.

B. DSPB-250 / DSPB-100 - Quick Start

1. Connect the included 3.5mm jack to port J6 for audio input.
a. Note – J3, the 3.5mm jack on the board, is NOT for audio input.

2. Connect speakers to J10 according to the wiring diagram or by following the labels on the back
side of the board. This will be different for the DSP-250 vs. the DSPB-100.
a. If using a DSPB-100, it is recommended to bridge the two positive wires together as well
as the negative wires.
3. Connect power through either J9 if using a power adapter or use J8 if using a battery board.
a. It is recommended to use a power supply of at least 15V but less than 24V.
4. Audio should now play if the above connections are made correctly.
a. Troubleshooting
i. Check the included 3.5mm jack is connected to the correct pins of J6.
ii. Check the position of the on board potentiometers that affect gain and high
pass filters.
iii. Check that your audio source is functioning correctly.
iv. Check the speaker connections match the corresponding diagram. There is a
different diagram for the 250 (stereo) vs the 100 (mono).
v. If you attached an ICP1, detach it and do a power cycle.
5. Adjusting the potentiometers on the board labelled POT1-4 will allow quick adjustments without
any programming. NOTE: If a KAB board is connected with the DSPB board through the audio
expansion port, POT1 and POT2 control the connected KAB board outputs.
a. POT1 – Headphone or audio expansion (J5 or J3) Gain
b. POT2 – Headphone or audio expansion (J5 or J3) High Pass Filter frequency adjustment
c. POT3 – Powered Speaker output (J10) High Pass Filter frequency adjustment
d. POT4 – Master Gain
6. Once the basic connection is working, the DSPB is ready to be integrated into your project.
Further customization can be done by using the methods below.
a. App connection with the ICP1 for basic EQ or high and low pass filter adjustment
b. Sigma Studio connection with the ICP1 for nearly infinite custom DSP possibilities.
i. See the sample project files at the Parts Express Product page for your device.
c. Connection of a DSPB-250 or DSPB-100 with a Dayton Audio KAB board to utilize all 4
DSP outputs of the Analog Devices ADAU1701 processor. An example of this
configuration is detailed in the Active 2-way guide below.

C. DSPB - K / DSPB - KE - Quick Start

1. Provide power to the micro-usb jack (J2)

2.

3.
4.

5.

6.

a. Note – the on board micro-usb jack will not provide access to Sigma Studio if hooked up
to a computer (but it can provide the DSPB-K power), an ICP1 is required for
programming with SigmaStudio or app control.
If using a DSPB-KE, using the provided 10 pin cable, connect J1 of the DSPB-K to J4 of the DSPB-KE.
a. Follow the wiring diagram to make the desired input and output connections to the
DSPB-KE. There are many possibilities for connections, including 3.5mm, RCA, and
headers. Each port is clearly labelled on the bottom of the board for easy connection.
If not using the DSPB-KE, a custom solution will be required to get input and output from the
DSPB-K. All inputs and outputs are exposed through the J2 header, and each pin has a clear label
on the board under this header.
Set the switch on the DSPB-K to ‘1’ for playback mode.
If all of the correct connections are made and power is connected, the device should be
functioning. If not –
a. Press the reset button on the DSPB-K.
b. Check the position of the potentiometers.
c. Check that your output device is functioning correctly.
d. Check the connection between the DSPB-K and DSPB-KE is secure on each board.
e. Check the 10 pin cable that connects the DSPB-K to the DSPB-KE
f. Check that your input device is functioning correctly
g. Check that the switch on the DSP-K is set to ‘1’.
Adjusting the potentiometers on the board labelled POT1-4 will allow quick adjustments without
any programming.
a. POT1 – Subwoofer Gain Control (this affects the output from J10 of the DSPB-KE, the
sub out port)
b. POT2 – Subwoofer Low Pass Frequency Adjustment
c. POT3 – Stereo High Pass Frequency Adjustment
d. POT4 – Stereo Gain Control
Once the basic connection is working, the DSPB is ready to be integrated into your project.
Further customization can be done by using the methods below.

a. App connection with the ICP1 for basic EQ or high and low pass filter adjustment
b. Sigma Studio connection with the ICP1 for nearly infinite, custom DSP possibilities.
i. There are sample project files available on the product pages for the devices.
See the SigmaStudio examples section of this document for further explanation.
c. Connection of a DSPB-250 or DSPB-100 with a Dayton Audio KAB board to utilize all 4
DSP outputs of the Analog Devices ADAU1701 processor. An example of this
configuration is detailed in the Active 2-way guide.

D. Potentiometer Controls
The following table puts all of the default potentiometer controls into one location. Note that these
controls are only guaranteed to be valid if Sigma Studio has not been connected to the DSPB. If you
program your DSPB with your own program, the potentiometers will work based on how you assigned
them in your project.
POT1
POT2
POT3
POT4

DSPB-250 / DSPB-100
Gain Control – J3 & J5
High Pass Filter Control - J3&J5
High Pass Filter Control for Speaker Output – J10
Master Volume Control – J10, J5, J3

DSPB-K
Sub Gain
Sub Low Pass Adjustment
Stereo High Pass Adjustment
Stereo Gain

E. ICP1 Sigma Studio Connection - Quick Start
Note: Sigma Studio connection requires a Windows PC. This guide requires a basic knowledge of
computer operation.
1. Download and install the most recent version of SigmaStudio to your system
2. Make sure your ICP1 is disconnected from USB and from your DSPB before starting, to ensure
the proper steps are taken.
3. Open an example project from parts-express.com, or use the following steps to setup the
‘hardware configuration’ menu in SigmaStudio. If using an example project, skip to step 5 after
opening it in Sigma Studio with File > Open.
4. Find the “USBi” block in the Communication Channels section of the tree toolbox and drag it in
to the white space like shown below.

5. Find the ADAU1701 and E2Prom blocks in the “Processors (ICs / DSPs)” section of the tree
toolbox and drag them into the white space like shown below. Then make the connections to
the USB block. The I2C addresses in the USB block will automatically populate, there is no need
to change them.
a. Note: In this image below, the “USB Interface” represents your ICP1, the ADAU1701 is
the processor on your DSPB, and E2Prom is non-volatile memory on the DSPB that
programs ultimately will be written to.

6. Ensure that your ICP1 is not yet connected to the DSPB, and ensure that its switch is set to ‘1’.
7. Plug a micro USB cable into the PC running SigmaStudio, and then connect the cable to your
ICP1.
a. Note: If the connection below is not successful, it is imperative to try a different USB
cable. Many micro USB cables endure a lot of abuse from charging devices, and
although they might still provide power, they might have issues transferring data. Some
micro USB cables struggle to ever work properly with data at all.
8. If all is correct, you will see the USB block turn green, like below.
a. Note that this means that SigmaStudio recognises your ICP1, it does not indicate that
SigmaStudio recognises your DSPB.

9. If not already, make sure your DSPB is connected to its own power source. If the ICP1 is plugged
into the DSPB, but your DSPB does not have its own power, it will light up LEDs on the DSPB
(making it look like it is powered), but it will fail to program and function.
10. Once the USB block is green, plug the 6-pin connector on the ICP1 to the 6-pin programming
port on the DSPB (J8 for DSPB-100 or DSPB-250, J11 for DSPB-K). Your ICP1 will come with this
cable.
11. Following these steps, you should be ready to create custom configurations for your DSPB.
12. If using a completely new SigmaStudio project, usage of the potentiometers on the board
requires additional configuration. If using a sample project from Dayton Audio, this should
already be configured, but is worth checking anyway.

a. Enter the “hardware configuration tab”. This is where you will see the green USB block
like above.
b. Towards the bottom of your screen, select the “IC 1 – 170x\140x Register Control” Tab
c. Configure the section labelled with the red box in the image below as the image shows.
Without this step, the potentiometers will not work.

2. Sigma Studio Examples and Guides
A. Creating a basic SigmaStudio project for the DSPB
The simplest project you could create in Sigma Studio is a project that directly routs the inputs to the
outputs, but in this brief tutorial we will also add a master gain control. Please follow the ICP1
SigmaStudio connection guide and quick start guide for your specific DSPB (found in the previous
section) before following these instructions.
1. Enter the “schematic” tab near the top of the screen. This is assuming your hardware
configuration is already complete from the ICP1 connection to SigmaStudio guide.

2. Find “Input” and “Output” under the IO folder in the Tree Toolbox ion the left side of your
screen. Drag 1 input and 2 outputs to the whitespace in the schematic tab.

DAC Assignment Table
DAC0
DAC1
DAC2
DAC3

DSPB-250
J10
J10
J3 or J5
J3 or J5

DSPB-100
J10
J3 or J5
J3 or J5

DSPB-KE
OUTR
OUTL
N/A
SUB

3. It is highly recommended to add hardware-controlled gain on any project. There are multiple
types of volume controls, but for this tutorial we will use a control that can be controlled with
one of the onboard potentiometers. From the tree toolbox, find “Single slew ext vol” under
Volume Controls > Adjustable Gain > Ext Control > Clickless SW Slew. Drag this item into the
schematic whitespace.

4. Right click the SW vol 1 control, and grow the algorithm by 1 like shown below. This will allow us
to pass both input 0 and input 1 through the same volume control by adding an additional input
and output.

5. Find “Auxiliary ADC Input” in the tree toolbox under IO>GPIO>Input. Drag this control into the
project, and then connect everything together as shown below.

a. Note: If you have not followed the exact steps of the ICP1 SigmaStudio connection
guide, your potentiometers might not work, as they require additional configuration.
b. Note: We are using AUX_ADC_0 for this, which corresponds to POT1, but any POT could
be used using the drop down menu for the ADC block.

6. It is now time to test the program. Press the “Link Compile Download” button shown below.

7. If everything has been done correctly, you will see “Active: Downloaded” in the bottom right
corner of your window.
8. If the error message below is seen, please refollow the ICP1 SigmaStudio Connection Guide
section and ensure that all steps have been followed in the proper order. This message can
occur by connecting the USB cable and 6 pin programming connector to the DSPB in the wrong
order. If refollowing that guide does not fix the error, see the troubleshooting section.

9. Once you have a design that you like, by pressing “link compile download” that design is only
saved to your DSP until the next power cycle. To permanently save your program, follow the
next section to save your program to E2Prom. To restore the original DSPB firmware (if writing
to E2Prom has not been completed), remove power from the DSPB, disconnect the ICP1 and
reconnect power to the DSPB.

B. Writing to E2Prom – Saving custom SigmaStudio programs to non-volatile memory
This step writes your custom program to non-volatile memory on the DSPB, which ensures that your
custom program runs on the DSP upon a new boot. This is essential for long term use, because when
you are connected to SigmaStudio testing configurations, that current program is stored in memory that
is volatile, meaning it is lost when there is a power cycle. If you find that your program is lost on a power
cycle, it means you have not written the program to E2Prom.
IMPORTANT – This step will erase the stock configuration of the board! This means that the default
functions of POT1-4 will reprogrammed or removed, depending on the SigmaStudio project that is
loaded. There is a project file on the website called “Stock_Firmware.dspproj” that will restore the
original firmware if you need It.
1. If choosing to do this step, it is highly recommended to tie one of the potentiometers of the
board to a master gain control (demonstrated in “Creating a basic SigmaStudio project for the
DSPB” above). Without this, it will not be possible to control gain without reconnecting to
SigmaStudio.
2. By this step, you should have successfully created a project and programmed it onto your DSPB
during the same session of SigmaStudio during which you will be writing to E2Prom. If you have
not successfully used the “Link Compile Download” button, you must before moving foward.
3. Right click your “ADAU1701” block and click “Write Latest Compilation to E2PROM”

4. In the window that opens, make sure the settings match what is in the screenshot below (they
are the default settings), and press OK.
a. NOTE: The ICP1 switch’s position must be at ‘1’ for this to work properly. If you get to
this point and realize it is set to ‘2’, you might be required to refollow the ICP1 sigma
studio connection guide again in order to write to E2Prom. Alternatively, try pressing
the reset button on the ICP1 after switching to ‘1’.

5. The program should now be written to E2PROM after it finishes programming. This means you
can remove your ICP1 from the DSPB, and your program should remain after power cycling the
DSPB.

C. Example – DSPB-250 2.0 Channel Sigma Studio Project.
This basic example project can be used with a DSPB-250 or the DSPB-K. Follow the quick start guide
above for your DSPB, and then read the ICP1 Sigma Studio guides above for how to use the project file
“DSPB-250 2.0 or 1.1 System.dspproj”. See below for a description of each labelled section, and note
that this is only an example of what you can do in SigmaStudio. You are encouraged to explore the
program yourself, and also to view other ADAU1701 projects and advice that can be found by searching
the web.

A. Input – Inputs 0 and 1 will correspond to the left and right channel of any audio input. For this
example, we assume a Bluetooth KAB board is not connected, so this input will correspond only
to the 3.5 mm jack hooked up to J6.
B. Gain Control – This master gain control is connected to POT1 on the DSPB.
a. It is recommended to make gain controllable with hardware, but this could be changed
to a slider type of control if desired.
b. If you want to use a different potentiometer for master gain, simply change AUX_ADC_0
to any of the other options in the dropdown menu.
C. EQ Section – SigmaStudio has many possibilities for this section, available by navigating through
the Tree Toolbox and paying special attention to the filters section. The parametric EQ found in
Filters > Second Order > Multichannel allows for visual adjustment of filters and is what we use
here as it is the most user friendly, but there are many other ways to achieve EQ. Click the blue
icon in the block
to adjust the PEQ.
a. Note: You might need to reflash your board by hitting the “Link Compile Download”
button to hear the results of adding a new filter in the PEQ mode.
b. Results with this PEQ can be dramatic. Take caution to avoid overloading speakers.
D. Filter Section – Here we have a high pass filter on each channel, acting as a subsonic filter to get
better output out of our ported speakers, but remove this filter altogether if it does not fit your
speakers.
E. Output Section –DAC0 and DAC1 represent the powered outputs of the DSPB.

D. Example – DSPB-100 Mono DSPB Sigma Studio Project.
This basic example project is intended to be used with a DSPB-100 mono board, and can be configured
to power a subwoofer or simply a full range mono speaker. Just change the filter appropriately. Follow
the quick start guide above for your DSPB, and then read the ICP1 Sigma Studio guides above for how to
use the project file “DSPB-100 Mono System.dspproj”. See below for a description of each labelled
section, and note that this is only an example of what you can do in SigmaStudio. You are encouraged to
explore the program yourself, and also to view other ADAU1701 projects and advice that can be found
by searching the web.

A. Input – Inputs 0 and 1 will correspond to the left and right channel of any audio input. For this
example, we assume a Bluetooth KAB board is not connected, so this input will correspond only
to the 3.5 mm jack hooked up to J6.
B. Gain Control – This master gain control is connected to POT1 on the DSPB.
a. It is recommended to make gain controllable with hardware, but this could be changed
to a slider type of control if desired.
b. If you want to use a different potentiometer for master gain, simply change AUX_ADC_0
to any of the other options in the dropdown menu.
C. Mixer – This section mixes the left and right channels to make a mono signal.
D. EQ Section – SigmaStudio has many possibilities for this section, available by navigating through
the Tree Toolbox and paying special attention to the filters section. The parametric EQ found in
Filters > Second Order > Multichannel allows for visual adjustment of filters and is what we use
here as it is the most user friendly, but there are many other ways to achieve EQ. Click the blue
icon in the block
to adjust the PEQ.
a. Note: You might need to reflash your board by hitting the “Link Compile Download”
button to hear the results of adding a new filter in the PEQ mode.
b. Results with this PEQ can be dramatic. Take caution to avoid overloading speakers.
E. Filter Section – Here we have a high pass filter as an example for a “1.0” mono system. If you
want to use this setup as an 0.1 system (just as a sub), change the high pass filter to a low pass
filter by clicking
F. Output Section –DAC0 or DAC1 represents the powered output on your DSPB-100.

E. Example - DSPB-250 + KAB250v3 – Active 2-Way Speaker, 4.0 System
An active 2-way system can be achieved by utilizing a DSPB-250 and any 2 channel KAB board tied
together. It is also possible to use this project with the DSPB-K with minimal modification. This setup not
only allows the crossovers to be done digitally, it also allows nearly infinite possibilities for EQ, precise
time alignment, bass enhancement and more. This allows for the usage of aux in (through J6 on the
DSPB) or Bluetooth audio from the KAB board. Do not rely on only this document to explore the
possibilities for this setup, as any documentation online that applies to the ADAU1701 should apply here
as well.
Note: The KAB board’s Bluetooth connection cannot be used to connect to the DSPB app, it is
only for audio streaming.

Required Items:
1.
2.
3.
4.

1 x Dayton Audio DSPB-250
1 x Dayton Audio KAB-250v3 (other models could be used for this)
1 x Dayton Audio Dayton Audio ICP1
A power supply.
a. This could be a single battery board, a single 24V power supply, or 2 identical power
supplies 15-24V.
5. 1 x Windows Computer Running SigmaStudio
6. PC Board M3 Standoff Kit (optional) this allows the board to be connected together physically.

Steps:
1. Connect J5 on DSPB-250 to J11 on KAB215v3 with a 6 pin cable (this connection shares the audio
back and forth between the boards). These ports are labelled with blue boxes in the image
below.

2. Connect power to both boards using the desired power source according to the DSPB Wiring
Diagram and the KAB250v3 wiring diagram.
3. Download “DSPB-250 + KAB 250v3 4.0 System.dspproj” file from the website.

4. Follow the “ICP1 Sigma Studio Connection - Quick Start” guide found above, utilizing the project
file you just downloaded.
5. Modify the project file to suit your project. To program it to your DSPB, follow the “ICP1 Sigma
Studio Quick Start” Guide found above, and then follow “Writing to E2Prom” to make sure your
custom program persists after a power cycle.
6. See below for a screen capture of the SigmaStudio project with descriptions of each section.

A. Input – Inputs 0 and 1 will correspond to the left and right channel of any audio input. This could
be could through an aux jack on the DSPB, or using the KAB215v3’s Bluetooth streaming (if both
inputs are present, inputs will mix)
B. Gain Controls – These controls are set up to hardware controlled. AUX_ADC_# blocks connected
to each volume control correspond to the potentiometers on the DSPB. The number in the
volume block is the slew rate time constant NOT volume. It is recommended to keep it at 12.
a. It is recommended to make gain controllable with hardware, but these could be
changed to a slider type of control.
C. EQ Section – SigmaStudio has many possibilities for this section, available by navigating through
the Tree Toolbox and paying special attention to the filters section. The parametric EQ found in
Filters > Second Order > Multichannel allows for visual adjustment of filters and is what we use
here as it is the most user friendly, but there are many other ways to achieve EQ. Click the blue
icon in the block
to adjust the PEQ.
a. Note: You might need to reflash your board by hitting the “Link Compile Download”
button to hear the results of adding a new filter in the PEQ mode.
b. Results with this PEQ can be dramatic. Take caution to avoid overloading speakers.
D. Crossover Section – This section is preconfigured for a test bench set of speakers, but it is fully
customizable by clicking the blue icon in the block
. This will bring up the appropriate
menu.
E. Delay Section – You might find it useful to have a delay block to time align your woofers with
your tweeter. In this case, the woofer sits further back from the tweeter, so we put a delay on
the woofer. Press ‘samples’ in this block to switch the representation to milliseconds. Please
note that this will affect your phase relationships.

F. Output Section – This might need changed depending on how you have wired your speakers.
This example uses one board for the left channel, and one board for the right channel. DAC0 and
DAC1 represent the outputs of the DSPB, and DAC2 and DAC3 represent the outputs of the KAB
board. It could also be configured that one board is woofers, one board is tweeters.

F. Example - DSPB-100 + KAB-250v3 or DSPB-250 + KAB-100M– 2.1 System
A 2.1 system can be achieved by utilizing a DSPB-100 and any 2 channel KAB board tied together. It can
also be achieved by using a DSPB-250 and KAB100M together (if using this configuration, you just need
to change the output section). It is also possible to use this project with the DSPB-K with minimal
modification, but there is a separate guide and project for that. This setup allows nearly infinite
possibilities for EQ, precise time alignment, bass enhancement and more. This allows for the usage of
aux in (through J6 on the DSPB) or Bluetooth audio from the KAB board. Do not rely on only this
document to explore the possibilities for this setup, as any documentation online that applies to the
ADAU1701 should apply here as well.
Note: The KAB board’s Bluetooth connection cannot be used to connect to the DSPB app, it is
only for audio streaming.

Required Items:
1.
2.
3.
4.

1 x Dayton Audio DSPB-100 (or DSPB-250)
1 x Dayton Audio KAB-250v3 (or KAB-100M)
1 x Dayton Audio Dayton Audio ICP1
A power supply.
a. This could be a single battery board, a single 24V power supply, or 2 identical power
supplies 15-24V.
5. 1 x Windows Computer Running SigmaStudio
6. PC Board M3 Standoff Kit (optional) this allows the board to be connected together physically.

Steps:
1. Connect J5 on DSPB-100 to J11 on KAB215v3 with a 6 pin cable (this connection shares the audio
back and forth between the boards). These ports are labelled with blue boxes in the image
below.

2. Connect power to both boards using the desired power source according to the DSPB Wiring
Diagram and the KAB215v3 wiring diagram.
3. Download the “DSPB + KAB 2.1 System.dspproj” from the website.
4. Follow the “ICP1 Sigma Studio Connection - Quick Start” guide found above, utilizing the project
file you just downloaded.

5. Modify the project file to suit your project. To program it to your DSPB, follow the “ICP1 Sigma
Studio Quick Start” Guide found above, and then follow “Writing to E2Prom” to make sure your
custom program persists after a power cycle.
6. See below for a screen capture of the SigmaStudio project with descriptions of each section.

A. Input – Inputs 0 and 1 will correspond to the left and right channel of any audio input. This could
be could through an aux jack on the DSPB, or using the KAB215v3’s Bluetooth streaming (if both
inputs are present, inputs will mix)
B. Gain Controls – These controls are set up to hardware controlled. AUX_ADC_# blocks connected
to each volume control correspond to the potentiometers on the DSPB. The number in the
volume block is the slew rate time constant NOT volume. It is recommended to keep it at 12.
a. It is recommended to make gain controllable with hardware, but these could be
changed to a slider type of control.
C. EQ Section – SigmaStudio has many possibilities for this section, available by navigating through
the Tree Toolbox and paying special attention to the filters section. The parametric EQ found in
Filters > Second Order > Multichannel allows for visual adjustment of filters and is what we use
here as it is the most user friendly, but there are many other ways to achieve EQ. Click the blue
icon in the block
to adjust the PEQ.
a. Note: You might need to reflash your board by hitting the “Link Compile Download”
button to hear the results of adding a new filter in the PEQ mode.
b. Results with this PEQ can be dramatic. Take caution to avoid overloading speakers.
D. Crossover Section – This section is preconfigured for our test speakers, but it is fully
customizable by clicking the blue icon in the block . This will bring up the appropriate menu.
E. Dynamic Bass Block – This is one of the many advanced algorithms from Analog Devices that can
be used on your DSPB. Simply delete it and reroute the wires if it is not wanted. For further
descriptions of this or any other block, explore Analog Devices’ SigmaStudio documentation
here.
F. Mixer – This block mixes the L and R signals together to create a mono channel for your sub.
G. Delay Section – You might find it useful to have a delay block to time align your subwoofer.
Please note that this will affect your phase relationships.
H. Output Section – This section is configured with the assumption that you are using a DSPB-100
as your subwoofer and your KAB board for your satellites. DAC0 is the output from the DSPB100 (or DAC1, but we use DAC0 in this case), and DAC2 and DAC3 are the outputs from your
attached KAB board. Change this section accordingly if you’re using a DSPB-250 with a mono
KAB board instead.

G. Example – DSPB-K + DSPB-KE – 2.1 System

By connecting an ICP1 up to a DSPB-K, it is possible to add all of the functionality of the Analog Devices
ADAU1701 to a system with an external amplifier. This setup allows nearly infinite possibilities for EQ,
precise time alignment, bass enhancement and more. Do not rely on only this document to explore the
possibilities for this setup, as most documentation online that applies to the ADAU1701 should apply
here as well.
Note: The micro-usb port on the DSPB-K cannot be used to connect to SigmaStudio, an ICP1 is
necessary to make this connection.

Required Items:
1.
2.
3.
4.

1 x Dayton Audio DSPB-K
1 x Dayton Audio DSPB-KE (recommended)
1 x Dayton Audio Dayton Audio ICP1
1 x Micro USB Cable and a power supply. Because of the USB connection, this could be a laptop,
TV, phone charger or almost anything with a USB port
5. 1 x Windows Computer Running SigmaStudio

Steps:
1.
2.
3.
4.

Follow the quick start guide above for the DSPB-K / DSPB-KE
Make sure your DSPB-K’s switch is set to 1.
Download the “DSPB-K and KE 2.1 System.dspproj” from the website.
Follow the “ICP1 Sigma Studio Connection - Quick Start” guide found above, utilizing the project
file you just downloaded.
5. Modify the project file to suit your project. To program it to your DSPB-K, follow the “ICP1 Sigma
Studio Quick Start” Guide found above, and then follow “Writing to E2Prom” to make sure your
custom program persists after a power cycle.
6. See below for a screen capture of the SigmaStudio project with descriptions of each section.

A. Input – Inputs 0 and 1 will correspond to the left and right channel of your audio input. This is
labelled AINL and AINR or the 3.5mm jack between them on the DSPB-KE.
B. Gain Controls – These controls are set up to hardware controlled. AUX_ADC_# blocks connected
to each volume control correspond to the potentiometers on the DSPB. The number in the
volume block is the slew rate time constant NOT volume. It is recommended to keep it at 12.
a. It is recommended to make gain controllable with hardware, but these could be
changed to a slider type of control.
C. EQ Section – There is extensive flexibility for this section. You are encouraged to explore
SigmaStudio’s possibilities for this block, by navigating through the Tree Toolbox and paying
special attention to the filters section. The parametric EQ found in Filters > Second Order >
Multichannel allows for visual adjustment of filters and is what we use here, but there are many
other ways to achieve EQ. Click the blue icon in the block
to adjust EQ.
D. Crossover Section – This section is preconfigured for a test bench set of speakers, but it is fully
E.

F.
G.

H.

customizable by clicking the blue icon in the block
. This will bring up the menu below.
Dynamic Bass Block – This is one of the many advanced algorithms from Analog Devices that can
be used on your DSPB. Simply delete it and reroute the wires if it is not wanted. For further
descriptions of this or any other block, explore Analog Devices’ SigmaStudio documentation
here.
Mixer – This section mixes the left and right channels to make a mono signal for the sub.
Delay Section – You might find it useful to have a delay block to time align your subwoofer. In
this case, the woofer sits further back from the tweeter, so we put a delay on the woofer. Press
‘samples’ in this block to switch the representation to milliseconds. Note that the
Output Section – This section is configured with the assumption that you are using a DSPB-100
as your subwoofer and your KAB board for your satellites. DAC0 is the output from the DSPB100 (or DAC1, but we use DAC0 in this case), and DAC2 and DAC3 are the outputs from your
attached KAB board.

3. Wiring Diagrams
DSPB-100

DSPB-250

DSPB-K

DSPB-KE

DSPB-ICP1

4. Tips and Troubleshooting
A. DSPB Tips and Troubleshooting
1. Noise
a. If a DSPB is connected to an ICP1, and that ICP1 is plugged into a computer, sometimes
noise can be picked up from the computer’s USB port. If this occurs, try a different USB
port and make sure to unplug your ICP1 from the PC when it is not in use.
b. If using a laptop, try disconnecting it from power if possible.
c. Turn the amp gain down and turn the input volume up. With the gain all of the way up,
it is expected to have more noise than with it at a lower gain.
d. Check to make sure there is not any damage to cables or ports.
2. The DSPB worked fine before powering it off, but powering it back on there is no sound.
a. This can happen if an ICP1 is connected to a PC, and that ICP1 is connected to a DSPB,
but the DSPB and PC are turned off. When both get turned back on, you might get no
audio.
b. The fix is simple, just unhook your ICP1 from the DSPB and plug it back in if desired.
Press the reset button on the DSPB if sound still does not come on when removing the
ICP1.
3. In general, pressing the reset button on the products in the DSPB series can help solve problems
a. Power cycling can help, as an alternative.
4. My DSPB doesn’t sound like a normal amplifier, something sounds wrong.
a. Try adjusting the potentiometers corresponding to the high pass filters on the board.
b. If using a stereo board, make sure to carefully follow the wiring diagram to ensure your
speakers are in phase with each other. Wiring speakers out of phase will make them
sound incorrect.
5. Follow the guides above closely.

B. ICP1 Sigma Studio Troubleshooting
1. Many problems, especially connection problems, can be solved with a reboot of your Windows
PC and then following the connection guide steps exactly from the start.
2. I cannot get my ICP1 to program.
a. Follow the ICP1 Sigma Studio Connection guide under the quick start section of this
guide. It is not enough to just make the correct connections, it is required to do the
steps in order to have consistent connection results.
b. It is important to try a different micro USB cable. Many micro USB cables endure a lot of
abuse from charging devices, and although they might still provide power, they might
have issues transferring data. Some micro USB cables struggle to ever work properly
with data at all.
3. I have my potentiometers set correctly in my SigmaStudio schematic, but they don’t work.
a. Ensure that the register control menu is set correctly to utilize the potentiometers. See
the section “ICP1 Sigma Studio Connection - Quick Start”
4. If I disconnect power from my DSPB, I lose my sigma studio configuration (the configuration
returns to default)

a. Ensure that you are writing the program to E2Prom once you are finished with
configuration. See section “Writing to E2Prom”

C. Sigma Studio Tips
1. Right clicking schematic blocks often reveals additional control for the block
a. Example, a volume controller can be “grown” to allow for multiple inputs and outputs to
pass through a single volume controller. This is done in step 4 of the “Creating a basic
SigmaStudio project for the DSPB” guide.
b. Right clicking any slider allows exact values to be entered
2. Hovering over elements in SigmaStudio project files can often reveal useful context about
whatever is being hovered over.
a. Example: Hovering over a “pin” of a block will reveal what that pin is.

3. Holding control and dragging a block allows quick duplication of that block
4. Right click any block and “Disable” the cell for quick comparison tests. You will need to link
compile download after doing this.
a. Note: The default password is blank, just press OK when prompted for a password.
5. Viewing Project Responses in Sigma Studio
a. Utilizing stimulus and probe functions allow you to see the response and phase of *your
project without needing to take measurements! Add stimulus to input, and probe to
output anywhere in your project, press the “stimulus” button, and then open the
“probe” button to view this response.

